Recent Posts

Pages: [1] 2 3 ... 10
1
ARM Cortex / Re: lpc11xc14 can bootloader at higher baudrate
« Last post by Andy Ayre on Today at 01:39:22 am »
No, it's not possible to change it. If we provided an option that doesn't work with the factory bootloader then tech support and frustrated users will increase.

Please email us at support at e s academy dot com for options.

Andy
2
ARM Cortex / lpc11xc14 can bootloader at higher baudrate
« Last post by VanDan on April 19, 2018, 11:43:50 pm »
hello,

we need to run the internal can bootloader of a lpc11c24 at 500kbaud. so we wrote a bootloader which behaves the same way as the internal bootloader except running with 500kbaud instead of the default 100kbaud.


is it possible to set the can baudrate to 500kbaud in flash magic gui? i don't find a way, so i tried to do it with fm.exe but this works only until 250kbaud. trying 500 kbaud displays the following error message:

"Connection failed: comms error (baudrate not supported)"

but the peak pcan pci card supports this baudrate.

i used following directives:

CAN(PEAK PCAN PCI, 500, 0x7D, 1000)
DEVICE(LPC11C14/301CAN, 12.000000, 0)
READSIGNATURE

thanks in advance.

kind regards
3
General Discussion / Re: Stall + Not authorized
« Last post by Andy Ayre on April 17, 2018, 01:15:25 am »
The LED blinking at FM start is a good sign. Did it do that as well as give the "not authorized" error?
4
General Discussion / Re: Stall + Not authorized
« Last post by GGD77 on April 16, 2018, 04:39:07 am »
Hi, will try doing it from my desktop at work. Currently my laptop with 10.9 programs and works correctly and I do not want to mess it up.
In any case, all 3 computers have always (independently from FM version) done the sound of USB connected device and all of them at 1st connection after installing/re-installing the driver have detected the "new device" and have installed the software. I even tried to connect the device before starting FM and vice-versa few times I also tried to reboot the computer after the first connection... until now... no joy

About the LED blinking on the device, it was always solid until I started the FM10.9 while the software was starting the LED started to blink and I thought it was a good sign. In fact, the elusive option to program the chip over the LPClink2 was there and allowed me to program the chip.

I tested one .hex from NXP works as detailed in the specs.
Regards
GGD
5
General Discussion / Re: Stall + Not authorized
« Last post by Andy Ayre on April 16, 2018, 03:27:54 am »
Can you please try this:

Install version 11.00.
Open a command window and go to the FM installation folder
Connect the LPC-Link2 with JP1 removed
Run:

  USBManger --list

What happens? What is output? Do you hear any bings/bongs from Windows? Does the LED on the Link2 start flashing?

Thanks, Andy
6
General Discussion / Re: Stall + Not authorized
« Last post by GGD77 on April 16, 2018, 03:22:33 am »
Hi, thanks for prompt reply

yes 3 different PCs give me the "not authorized" error at start-up. One of them (the 1st I tried) also hides the message in the background and I could not see it/read it. It was appearing briefly on the foreground of the opened windows only when I was killing the main FM process from task manager.

Anyway I tried the "roll-back the date trick" does not work.

RE removing JP1
this was the first thing advised in many forums/tutorials for FM including on the NXP documentation I have tried: no joy... and anyway the device was always recognized in device manager at each test.

Last minute update:

Version 10.9 without changing any settings on the LPC-link2 worked... I just did this trial end error uninstalling and re-installing driver+FM for all the versions I could download. the oldest and my last chance just did it... all the others give me the "not authorized" message

Just now I have successfully erased the NHS3152 chip in the evaluation kit I recently purchased. Later will try to flash one of the other example .hex I know can be downloaded from the NXP page.
Regards
GGD
7
General Discussion / Re: Stall + Not authorized
« Last post by Andy Ayre on April 16, 2018, 01:19:06 am »
Close FM
Remove jumper JP1 from the LPC-Link2
Connect the LPC-Link2 to your PC - make sure it is recognized by checking in device manager
Start FM

Currently FM only checks for attached debug hardware on startup.

Do you have three different PCs giving the "not authorized" error?
8
General Discussion / Re: Stall + Not authorized
« Last post by GGD77 on April 16, 2018, 01:05:46 am »
Hello, I am new to flash magic but I worked with many processors before. I installed flash magic (latest downloaded a couple of days ago) and I have the same problem. However, even after I push OK when the message appears I have problems. It does not recognize the LPC-Link2 I have bought together with a NXP evaluation board.
I followed the instruction to install the driver, the LPC is correctly listed in the device manager but I cannot select "SWD over Link2" because it is simply not there... am I missing something? or has the "not authorized" error something to do with it?
I configured the switches as per NXP instructions... what can I attempt???
I tested 3 different PCs all run Win7 64 and they are all updated...

Cheers
GGD
9
General Discussion / Re: Slow download which bugs out Chrome
« Last post by Andy Ayre on April 12, 2018, 03:21:38 am »
Thanks for the additional information. Looking at the web server logs and your IP address there is an error message that indicates the connection is being prematurely closed at the client before the server had chance to respond. In this case the result is error code 500 - Internal Server Error, which is misleading. My guess is that a slow connection somewhere along the way was causing your browsers to give up just at the point where the web server was about to send a response.
10
General Discussion / Re: Slow download which bugs out Chrome
« Last post by buzmeg on April 12, 2018, 12:28:52 am »
Well, today I am seeing speeds of about 100KB/sec so I can actually download it with any browser.  (I note that this is ver 11.01 and not 11.00).

It's certainly possible that there is routing issue, but I'm suspicious.  I tried to access this from behind our corporate ISP (AT&T Business) and my home ISP (Cox Communications).  Both had the same failure.  MY CTO had the same problem from his home ISP.

Interestingly, wget pulls it down smoking fast on Linux (450+ KB/sec).  I'm an idiot for not trying that earlier.  Sorry.

However, that points to something going on at the server (broken browser detection maybe?  IPv6/IPv4 issue? HTTP/2 or SPDY?)

$ shasum -a 256 FlashMagic.exe
8ea579433cbd466e9c4dd1fc92295e25309d4bf3bff041d8068aa9ea530d0664  FlashMagic.exe

In addition, at roughly midnight PST, I got the following when I attempted to download:
http://www.flashmagictool.com/download.html&d=11.01/FlashMagic.exe


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Web Server at flashmagictool.com

Pages: [1] 2 3 ... 10