Author Topic: Problem Flash Magic and LPC935  (Read 5160 times)

Dominik Geiser

  • Guest
Problem Flash Magic and LPC935
« on: June 27, 2004, 09:04:39 am »
Hello!

I'm an electronic apprentice from Switzerland. Recently I bought the Keil Evaluation Board MCB900 Vers. 4, with the Philips P89LPC935 Controller.
But I can't program it with the provided Flash Magic Software.
I also loaded the newer Version 1.99, but it is allways the same problem:
"Unable to connect at the specific baud rate. .....". I read many similar topics in this Forum and tried all the tipps they got, but without any success...
I think the problem is not the serial cable, because if I start the Windows Hyperterminal, I see the "Hello World" Messages. This Hello World Program was already programmed at the controller, I think.

I hope you can help me! Thank you very much and have a nice time,
Dominik Geiser

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2163
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem Flash Magic and LPC935
« Reply #1 on: June 28, 2004, 08:28:01 am »
Are you placing the device into ISP mode? To do that you need to:

Remove power
Move the jumper from the "Run" position to the "Reset" position
Apply power

Make sure you have the correct device selected in Flash Magic, and you are using the baud rate that Flash Magic recommends (7200 or 9600 baud).

Embedded Systems Academy, Inc.
support at esacademy dot com

Dominik Geiser

  • Guest
Re: Problem Flash Magic and LPC935
« Reply #2 on: June 28, 2004, 02:27:15 pm »
Yes, I did that all, for several times... :-)
In the Version of Flash Magic, that was included, there was no Device for the LPC935, thats why I loaded Vers. 1.99.
I tried it with Baud rates down to 520, because i thought it could be that the cpu clock is made by the Watchdog Oscillator on 400 kHz.

I really dont know what else it could be, I read in this forum something about; "no ISP mode if the watchdog is active." Could something like that be the problem?

Thanks for further informations, Dominik Geiser

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2163
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem Flash Magic and LPC935
« Reply #3 on: June 29, 2004, 08:31:14 am »
Unless you set the CPU to run off the watchdog clock, then it is running off the internal RC oscillator. ISP mode works with the watchdog active on the LPC935. It is the LPC932 that has that problem.

In the advanced options, have you checked the option to enter ISP mode using DTR and RTS? That needs to be turned on. Also under Security in the advanced options, ensure Protect ISP is turned on.

If you already have those options turned on then:

Power down the board
Put the jumper on Reset
Power up the board
Start Flash Magic
Ignore the error about unable to connect
Select 7200 baud
Press F1 so [Debug] appears at the top
Choose Read security bits from the ISP menu
Did you get an error?
Close Flash Magic
Email me the generated file C:\flashmagic.fmd
Delete C:\flashmagic.fmd

My Email address is below.

Embedded Systems Academy, Inc.
support at esacademy dot com

Francois Spies

  • Guest
Re: Problem Flash Magic and LPC935
« Reply #4 on: August 02, 2004, 07:07:54 am »
Hi,

I have exactly the same problem using the same hardware. If I put a new blank chip in the socket, however, I can program it once only (with the "hello" example).

Regards
Francois Spies


erikm

  • Guest
Re: Problem Flash Magic and LPC935
« Reply #5 on: August 02, 2004, 08:13:36 am »
>>I put a new blank chip in the socket, however, I can program it once only (with the "hello" example)<<

All chips, when fresh, are in ISP mode.

if you install "Touchless" ISP for the Philips 89LPC935 by Lex Timmerman ( bottom of FlashMagic paghe) all your worries will be gone and the birdies will sing.

Erik

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2163
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem Flash Magic and LPC935
« Reply #6 on: August 02, 2004, 08:35:52 am »
If you can only program it once, and you are not using the NoTouch method or the break entry method, then you are not getting the ISP entry correct.

Do you have a jumper on "Reset" and no jumper on "Run"?
Have you turned on the Hardware entry option in the Advanced Options?
Did you leave the Protect ISP option checked? It should be checked all the time!

Embedded Systems Academy, Inc.
support at esacademy dot com