Author Topic: Problem in PAB90x  (Read 8173 times)

kiran v. sutar

  • Guest
Problem in PAB90x
« on: October 28, 2004, 09:03:00 am »
Hi Forum Members,
    I have downloaded me900.chm.
   As per the circuit schematic given in this file, I have built the MCB900.

   I have downloaded the file prog90x.hex and programmed it into the LPC932. Till here everything is fine.
   Now I want to program the LPC902.
   When I turn ON the power, the LED P3.2 does not light up.
I tried the following conditions:

  PROG   RUN    RESET
    YES     NO      NO
    YES     NO      YES
    YES     YES     NO
    YES     YES     YES

with all the above cominations, after power ON the LED P3.2 does not light up. I checked the signal P3.2 (CPU) it is low, never goes high.

IN Flashmagic I selected device as P89LPC902. When I give Read Device Signature, it gives "FF,FF,FF".

I don not understand what is wrong?

Can anybody guide me for the above?

Bye and thanks from,
Mr. Kiran V. Sutar.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2124
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem in PAB90x
« Reply #1 on: October 28, 2004, 05:18:46 pm »
When the signature returned is FFH, FFH, FFH that means the device is not entering ICP mode.

Go to the Flash Magic web page and scroll down to Third Party Documentation and Resources. Click on the link for AN10258 - the latest Philips app note on using ICP. A schematic diagram has been revised to change a transistor.

Embedded Systems Academy, Inc.
support at esacademy dot com

Mr. Kiran V. Sutar

  • Guest
Re: Problem in PAB90x
« Reply #2 on: October 30, 2004, 01:11:27 am »
Hi Andy,
            Thanks for your reply.
            I have downloaded the latest app note AN10258_2.pdf, it is the same I had downloaded before. The app note dated: March 2004.

            I am using  the BC177 transistor and a 4k7 resistor as mentioned in the app note. I have given the emiiter of the transistor to +V (i.e. the output of the regulator).
            The power supply I have taken is  a 9Vdc input from SMPS Adaptor => 7805 regulator => Series diodes (2Nos.) 1N4007. The voltage measured on the multimeter is 3.50 Vdc. Availability of 3.3V regulator is a problem in my city. Do you think I should use any other power supply circuit? As it is, even with this power supply the LPC932 is returning FFs, hence I think voltage might not be the problem.

             When I give "Read Device Signature" there is no activity on P2.3 of LPC932. (I have checked the activity on LPC932 on P2.3 and the output pin of 74LVC244.) And it shows "FF, FF, FF". What could have gone wrong?

             I tried by downloading the Prog90x.zip from esacademy.com and fired this program in 3 different LPC932, all give the same problem.

            Could you give me any futher suggestions or further tests to perform on this board.

Bye and Thanks from,
Mr. Kiran V. Sutar.

Mr. Kiran V. Sutar

  • Guest
Re: Problem in PAB90x
« Reply #3 on: October 30, 2004, 01:20:26 am »
Hi Andy again,
     I have re-downloaded both the links AN10258_1.pdf and AN10258_2.pdf from the philips website, and compared both the files, they are word-to-word same. There is no difference between them, they are one and the same file. If possible can you post a link to the proper application note.

Bye,
Mr. Kiran V. Sutar.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2124
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem in PAB90x
« Reply #4 on: October 30, 2004, 02:30:18 pm »
Figure 5 has been corrected. A different transistor is specified. I guess you missed the revision history on page 2?

Embedded Systems Academy, Inc.
support at esacademy dot com

Mr. Kiran V. Sutar

  • Guest
Re: Problem in PAB90x
« Reply #5 on: October 31, 2004, 12:59:07 am »
Hi Andy,
            As mentioned in my previous post both the files AN10258_1.pdf and AN10258_2.pdf are the same files, (word-to-word). I have compared them page by page by opening the 2 files simultaneously. There is no difference between the 2 files, I have downloaded both the files again and again, but still they are the same files. I have checked them today morning again, still they are the same files.

           Both the files on the first page mention the following:
Rev. 01

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2124
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem in PAB90x
« Reply #6 on: October 31, 2004, 06:24:05 am »
I don't know which files you are looking at, but the copy on the Flash Magic web page says "Rev. 02 - 21 October 2004" on the first page.

Perhaps you need to clear your browser cache? Sometimes Internet Explorer can make you think it downloaded a file, when it really just fetched an old file from it's cache.

Embedded Systems Academy, Inc.
support at esacademy dot com

shiue

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: Problem in PAB90x
« Reply #7 on: November 12, 2004, 08:48:29 pm »
I have email AN10258_2.pdf to you.