Author Topic: LPC2136 ISP difficulty  (Read 4749 times)

PhilipW

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
LPC2136 ISP difficulty
« on: August 30, 2006, 08:28:42 am »
I've been programming some boards with an LPC2136 without any problems but the end of the batch have been failing during programming.

Operation Failed. (programming - failed to send data to the device)

After this it says "finished" and increments the counter/plays the sound as if there was no error.


I've noticed there is a different date code on the chips that don't program - is it possible they are different?

I'm using FLASHMagic 3.24.123 and 11.0592MHz crystal at 57600 baud.

All chips show device revision 196387 and bootloader 1.1

Working boards have markings
S60706.1 05
ZPG0540B

Others have
S60799.1 06
ZPG0618B

Help!


Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2156
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC2136 ISP difficulty
« Reply #1 on: August 30, 2006, 08:58:58 am »
Complete the following steps:

Start FM

Connect a working board.
Press F1 to enter debug mode ([Debug] appears at the top of the window)
Program the device
Press F2 to exit debug mode
Rename C:\flashmagic.fmd to C:\flashmagic_working.fmd

Connect a non-working board
Press F1 to enter debug mode
Attempt to program the device - wait for the error message
Press F2 to exit debug mode
Rename C:\flashmagic.fmd to C:\flashmagic_failed.fmd

Email both .fmd files to me and then delete them. My Email address is at the bottom of this posting and in the Help -> About window

Embedded Systems Academy, Inc.
support at esacademy dot com