Author Topic: Problem in using flash magic with LPC2468  (Read 6343 times)

rkanthp

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
    • Email
Problem in using flash magic with LPC2468
« on: June 18, 2007, 06:57:33 am »
Hi friends,
I am new to this community.Well I have a small doubt. can any one help me?

I have one ".hex" file and while I am trying to write this file to LPC2468 flash memory using flash magic

I am getting message
"failed to read the device signature.Accessing a device using the wrong protocol could render the device
 unusable. do you wish to continue?"

I made the settings as below

COM port     COM1
Baud rate    115200
Device        LPC2468
Interface     ISP(None)
Osc Freq     12 MHz


Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem in using flash magic with LPC2468
« Reply #1 on: June 18, 2007, 09:12:16 am »
The device is probably not entering ISP mode. Try going to the ISP menu and attempting to read the device signature. If you are using an off the shelf board then double-check your jumper settings. Also look here:

  http://www.flashmagictool.com/debugstart.html

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

Abhishesh

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
Re: Same problem with LPC2378-SK Board
« Reply #2 on: October 09, 2007, 06:38:38 am »
I am facing the same problem and tried your solution but no success  :(
I think i have gone wrong somehere. something thats too obvious and overlooked

I have enabled the ISP_E jumper in LPC2378-SK board

I tried connecting to the board with the following settings:
    . 8 bits
    No parity
    One stop bit
    No handshaking or flow control
    9600 baud
    No local echo

I checked the Serial Cable also by short circuiting Tx and Rx pins its fine
I am using a generic Serial Cable (Do we need some special cable ????)

I couldn't get the echo on sending '?' to the device

Pls help !!!


 

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Problem in using flash magic with LPC2468
« Reply #3 on: October 09, 2007, 08:34:05 am »
You need to check that you are meeting the requirements to place the device into ISP mode. I believe on this device it is holding a pin on port 2 low during reset. So put a scope on the reset pin and the ISP pin and make sure it is low during reset.

If it is then put a scope on the RxD pin of the device and make sure the '?' is arriving. Next check the TxD pin. More details are here:

  http://www.flashmagictool.com/debugstart.html

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com