Author Topic: LPC 2387 with LPC 2368 settings.  (Read 7390 times)

LPC_2387

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
LPC 2387 with LPC 2368 settings.
« on: March 31, 2008, 01:51:14 pm »

Hi All,

I soldered and wrapped a LPC 2387, then I connected Flash Magic on the UART0 and I saw the flash display memory, tried a fill and it worked.

I compiled a known program with a LPC 2368 setting in Keil MDK-ARM 3.2 instead of LPC 2387 because the device is not the project options of the Keil toolchain or IAR KickStart, then I downloaded the hex file in the chip and tried to run the program.

Nothing, the program doesn't work and after when I wanted to return into the device with Flash Magic I obtained the following message :

Operation Failed. (failed to autobaud - step 1).

I can't connect to the chip.

I thought if I took a very close relative of the LPC 2387, like the LPC 2368, I will not have problems because there are very similar in flash size, addresses modes and so on.

Now I saw it doesn't work at all.

I have made a mistake with this assumption.

Did I lost my chip ?

I would like to know if it is possible to recover my chip with Flash Magic and then wait for a version of Keil or IAR that supports the LPC 2387.


Regards.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC 2387 with LPC 2368 settings.
« Reply #1 on: April 01, 2008, 08:59:52 am »
Your device is probably OK. Use an oscilloscope to make sure you are meeting the requirements for ISP entry as described in the user manual for the LPC2xxx family. I suspect that is where the problem is.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

hamsacomputronics

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
    • Email
LPC 2368 failed to autobaud - step1
« Reply #2 on: December 02, 2008, 08:15:01 am »
Dear Andy, 

       Me too facing same problem but difference is I was able to do programing the chip but after few times, It stopped working and giving error "failed to autobaud - step1" 
      Once I tried connecting COM0 to Hyperterminal and typed "? " few times.  is it created any problem?
      I am able to program chip with ULINK.  Please help me.
      as few posts says I have attached flashmagic.fmd file along with this post.

Regards,
Padmanabham

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC 2387 with LPC 2368 settings.
« Reply #3 on: December 03, 2008, 02:23:58 pm »
Using Hyperterminal shouldn't have caused any problem. If you try it now and send the '?' do you get "Synchronized" back? If not then the device is not entering ISP mode and therefore Flash Magic won't work.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com