Author Topic: P89C664 trouble, desktop pc vs laptop  (Read 4916 times)

raigo176

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
P89C664 trouble, desktop pc vs laptop
« on: July 18, 2008, 05:50:32 am »
Hello,
i am having trouble with the P89C664. When i use my desktop PC it works fine, i am able to program the device. When i try to use it on my laptop with exactly the same setting it just does not work. It says something like that: "Unable to connect at the specified baud rate. Try reducing baud rate. Reset the hardware into ISP mode again". It cannot find the device. Both computers use Windows XP. I also use a USB->R232 converter on both computers. Where could the problem be? Btw, reducing baud rate does not work, i have also tried changing COM port numbers.

ty
« Last Edit: July 18, 2008, 05:56:42 am by raigo176 »

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2156
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: P89C664 trouble, desktop pc vs laptop
« Reply #1 on: July 18, 2008, 10:24:12 am »
Are you using the exact same USB to RS232 cable? They are frequency a cause of problems.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

Jan Waclawek

  • Full Member
  • ***
  • Posts: 220
    • View Profile
    • EFTON homepage
Re: P89C664 trouble, desktop pc vs laptop
« Reply #2 on: July 23, 2008, 12:13:02 am »
Are you using the exact same USB to RS232 cable? They are frequency a cause of problems.
Also, a different driver to that "cable" might make a significant difference...

JW