Author Topic: MCB900 ICP brigde LPC921 unable to erase & flash sectors > 0  (Read 4195 times)

notedopjes

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
MCB900 ICP brigde LPC921 unable to erase & flash sectors > 0
« on: August 01, 2008, 03:36:49 am »
Hi,

I use the MCB900 board with the ISP to ICP bridge code into it to program a LPC921.

The first time i progam a LPC921 it works all as expected.

However when i try to reprogram the part, only the lowest sector (or block) gets erased and rewritten.

I am pretty sure this has nothing to do with build settings, because when i do a erase in FM of all sectors followed by a blank check, only the lowest sector is blank. Sectors 1 and up remain unchanged. I checked the security bits, they are all 0.

Anyone got a clue of what is going on here? And even better how to fix it?

Is there a way of doing a global erase command with the FM tool (with the ISP to ICP bridge)? Maybe that gets things working again.

I tried 3 different LPC921's all the same problem.

I also noticed that the CRC's never are as expected.

Reprogramming an application what fits entirely into sector 0 does work. However after doing that for a couple of times, the device wont run anymore (bit still is recognized by FM though).

Best regards,

Marc

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: MCB900 ICP brigde LPC921 unable to erase & flash sectors > 0
« Reply #1 on: August 07, 2008, 10:10:48 am »
Could it be that you have glitches on the ICP side of the communications path?

To perform a full device erase ensure you have the ICP bridge selected as the interface and Protect ISP disabled in the advanced options. Then go to ISP -> Erase and choose to erase all the flash.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com