Author Topic: "failed to autobaud" on LPC2478  (Read 7405 times)

Serge Issakov

  • Jr. Member
  • **
  • Posts: 3
    • View Profile
"failed to autobaud" on LPC2478
« on: September 22, 2008, 12:54:05 pm »
I'm running FlashMagic 4.30.1363 trying to flash an LPC2478 with a hex file from Embedded Artists.
I have verified that I can talk to the LPC2478 through the COM port I'm using (COM4) - which is setup as a USB serial port.  That is, I can connect to the port with Hyper Terminal at 115200, reset the board, and clearly read the startup boot text from the board inside the Hyper Terminal window.

But when I try to use FlashMagic  I just get an error.  I have the COM Port set to "COM 4" , I've tried all baud rates between 9600 and 115200, Device is set to "LPC2478", Interface is "None (ISP)", and I leave Oscilator at 16.0000 Mhz. 

Yet whenever I click Start I get a dialog box that says "Operation Failed. (failed to autobaud - step 1).

Any ideas?

Thanks,
Serge

Serge Issakov

  • Jr. Member
  • **
  • Posts: 3
    • View Profile
Re: "failed to autobaud" on LPC2478
« Reply #1 on: September 22, 2008, 05:00:30 pm »

Problem solved.

Turns out the jumpers are set by default to disable ISP.  Once I shorted both "automatic ISP jumpers", it's happily programming.

It looks like these instructions are in the user guide, but they're garbled in both version B of the LPC2478 OEM Board (p31) and in version C (p. 36).

Serge

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: "failed to autobaud" on LPC2478
« Reply #2 on: September 24, 2008, 08:38:48 am »
Thanks for taking the time to post the solution. This will help others that run into the same problem.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com