Author Topic: LPC2387 ISP auto baud problem In ISP  (Read 38040 times)

seema

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #660 on: June 17, 2009, 08:59:32 pm »
Hello,

can you Please suggest me another compatible device in 23XX ?



Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #661 on: June 18, 2009, 09:21:58 am »
Changing the device may or may not help. It depends what is causing the problem. We aren't seeing this problem from other people so that makes me think it is something to do with your hardware design, serial cable or PC.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #662 on: June 18, 2009, 09:23:13 am »
Another thought is to compare the schematics of the Keil MCB2300 with your board (www.keil.com/mcb2300). Look for differences. You might want to consider buying one of these boards to test with (www.lpctool.com).

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

seema

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #663 on: June 19, 2009, 04:43:08 am »
hello sir,
can you please attach the standard  schematic if you have.
i have tried to have it from the specified site but can not.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #664 on: June 19, 2009, 09:43:21 am »
Go to the page I gave you. Click on "Schematics" in the column on the left. Make sure you have Adobe Reader installed.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

seema

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #665 on: June 22, 2009, 12:23:56 am »
 :)I have checked with the schematic.
But i have not found the any dissimilarity.
 ::)except the pumping of pin P2.10
In the circuit it is automatic
& in my circuit it is manually i m doing it.
 :)Any way as there is no code programmed.After power on the control goes to boot loader only.
 :(Mean while i talked with NXP ,they have demanded me to send the hardware board.
can you send me the code for flash magic which will not go for auto baud?As in terminal i am getting the response for command ok @9600,19200.except the garbage for the synchronized



Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC2387 ISP auto baud problem In ISP
« Reply #666 on: June 22, 2009, 09:16:31 am »
Getting Flash Magic to ignore an incorrect response from the device is not the solution. Something is wrong and you need to get to the bottom of it. If you ignore this then the problem may show up in other, unexpected ways. As I mentioned before we don't have reports of anyone else seeing this problem. If NXP have offered to look at your hardware then I suggest you send it to them.

Please post back with what you hear from NXP.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

hecongling

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Re: LPC2387 ISP auto baud problem In ISP
« Reply #667 on: July 24, 2009, 12:55:14 am »
hello sir
     I have the same problem ,can you give me a way how to solve?