Author Topic: Philips LPC2000 Flash Utility works but not Flash Magic  (Read 10679 times)

jjacobsen

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Philips LPC2000 Flash Utility works but not Flash Magic
« on: October 14, 2009, 05:38:53 am »
I can load the flash on my LPC2106 board with the Philips LPC2000 Flash Utility.  When I use Flash Magic I get an autobaud failure.  I can only get Flash Magic to successfully communicate to my board when I am using a Keil ULINK2 and the uVision debugger is running (using secondary JTAG pins).  When the debugger is not running, Flash Magic will not work.  In both cases, DTR and RTS are high to begin with, as seen on the scope.  I have followed Keil's instructions on setting up Flash Magic and using the scondary JTAG.  I have 'use DTR and RTS to control RST...' checked in Flash Magic.  It's version 4.34.1437. 

I can continue to use the Philips utility but want to know why Flash Magic will not work.  Any ideas?

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2155
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Philips LPC2000 Flash Utility works but not Flash Magic
« Reply #1 on: October 14, 2009, 09:02:38 am »
Please generate and send us a debug file. Instructions are here:

  http://www.flashmagictool.com/debugfile.html

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

jjacobsen

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Re: Philips LPC2000 Flash Utility works but not Flash Magic
« Reply #2 on: October 16, 2009, 05:32:05 am »
Here are 2 debug files.  The 'failed' one was generated when I tried to do ISP -> Read Device Signature.  The 'ok' one is when I did the same thing with the uVision debugger running.
Thanks for your help on this.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2155
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Philips LPC2000 Flash Utility works but not Flash Magic
« Reply #3 on: October 16, 2009, 09:34:13 am »
Go to Options -> Advanced Options -> Communications and disable the high speed options feature. Does that change anything?

If not try disabling the DTR/RTS option and manually place the device into ISP mode. Does that help at all?

How are you placing the device into ISP mode when using the old Philips tool?

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com