Author Topic: Flashmagic need restart  (Read 2262 times)

suhelshaikh21

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Flashmagic need restart
« on: March 21, 2014, 09:31:20 pm »
Hello Everyone,
I am having p89v51rd2,
I am connecting it with my laptop using usb to serial cable & DB9 connector.
its work good first time only with boud rate9600.
but after that second time if i connect it was give me error unable to connect try to reduce baudrate, with same setting
if i restart my laptop & then i connect now it load programe again(i.e i require restart of my laptop every time when i using flshmagic)
how to solve this issue

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2108
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Flashmagic need restart
« Reply #1 on: March 24, 2014, 01:10:39 am »
Please try a USB to RS232 cable from a different manufacturer and see what happens. My first guess is that it is a driver issue.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

suhelshaikh21

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Re: Flashmagic need restart
« Reply #2 on: March 24, 2014, 09:21:14 pm »
I am changing usb to rs232 cable.
but result are same.
if i change pc then no need to restart

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2108
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Flashmagic need restart
« Reply #3 on: March 25, 2014, 01:37:21 am »
It must be something specific to your windows installation. There is nothing in Flash Magic that requires a reboot to continue using it and we don't have anyone else with any similar kind of issue.

I suggest to look at the low-level comms using PortMon then check to see what is different the first time (working) and the second time (fails).

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com