Author Topic: 89c668 ISP  (Read 3404 times)

SU

  • Guest
89c668 ISP
« on: January 14, 2004, 01:55:02 am »
Hi,

     after two days troubleshooting and not changing any hardware, tonight it finally works. i still don't quite understand why.

     now the new problem is that every time i turn on the power supply for 8051 board and ISP interfacing board (2 max232 on it to hardware generate RST and PSEN), i can download the firmware twice; sometimes even cannot download once. it says " unable to access COM port. Ensure no other applications are using the device. try rising or lowering baud rate".

     however, without changing anything, i then turn off the power and after a while turn no again, i can download the firmware again.

     any suggestion is appreciated.

guodong
thanks


erik malund

  • Guest
Re: 89c668 ISP
« Reply #1 on: January 14, 2004, 04:32:54 am »
>>max232 to  generate RST ...however, without changing anything, i then turn off the power and after a while turn no again, i can download the firmware again.<<

I have NEVER heard of the MAX232 as a reset generator.  The very symptoms you see should tell you to install a proper supervisor chip.

Erik

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: 89c668 ISP
« Reply #2 on: January 14, 2004, 06:17:48 am »
Do you have both P2.6 and P2.7 pulled high when resetting the device into ISP mode? Only pulling one of them high can lead to erratic results.

Embedded Systems Academy, Inc.
support at esacademy dot com