Author Topic: Auto baud issue with LPC1788  (Read 4441 times)

pge

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
    • Email
Auto baud issue with LPC1788
« on: March 12, 2015, 08:38:49 am »
Dear all,

I am using FlashMagic to flash an LPC1788 on a custom board.
I have already been able to correctly flash some LPC1763 using same USB to serial cable and same configuration.
I am using FlashMagic 8.96.3850

With the LPC1788 I almost always get the auto baud error. I have checked any point in autobaud issue page and everything seems ok.
I have checked signals with a scope and that seems ok. I have connected my logic analyser on both RX and TX and found everything correct, the LPC1788 answer with the "Synchronized\r\n" command. I have tried to send from the FashMagic terminal the sync character '?' and get the following answer: "" instead of the expected "Synchronized\r\n".

Accordingly to my logic analyser the bit rate of the answer is 108108 bits/s instead of the expected 115200.
I have tried to reduce speed to 38400 and the LPC1788 answer at 37735. For 19200 the LPC1788 answer at 19323.

Does anybody have any idea why my LPC1788 answer using the wrong speed ? I have no external quartz and use the internal RC oscillator.

Thanks in advance
« Last Edit: March 12, 2015, 08:43:18 am by pge »

pge

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
    • Email
Re: Auto baud issue with LPC1788
« Reply #1 on: March 12, 2015, 08:45:14 am »
-- Removed
« Last Edit: March 12, 2015, 08:47:53 am by pge »

pge

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
    • Email
Re: Auto baud issue with LPC1788
« Reply #2 on: March 13, 2015, 07:56:19 am »
Up. No idea ?

pge

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
    • Email
Re: Auto baud issue with LPC1788
« Reply #3 on: March 16, 2015, 05:27:28 am »
Just found the following in the ES_LPC177x/8x errata sheet:

Quote
3.8 ISP.1
Introduction:
In-System Programming (ISP) is programming or reprogramming the on-chip flash
memory, using the boot loader software and UART0 serial port. This can be done when
the part resides in the end-user board.
Problem:
UART ISP cannot be used at rates higher than 57,600 bits per second.
Work-around:
UART ISP must be used at 57,600 bits per second or a lower communications speed.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2160
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Auto baud issue with LPC1788
« Reply #4 on: March 21, 2015, 09:24:28 am »
Is FM able to communicate at slower speeds? In general up to 3% error in speeds can be tolerated.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

pge

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
    • Email
Re: Auto baud issue with LPC1788
« Reply #5 on: April 28, 2015, 04:16:13 am »
Sorry for late reply, yes it works at 57600 as specified in the errata