Author Topic: SWD over Link2  (Read 9516 times)

psh

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
Re: SWD over Link2
« Reply #15 on: August 21, 2017, 09:09:35 am »
Can't get SWD to work over LPC-LINK2 either. Keep getting the autobaud  error.

For reference, the same pins can be used with Keil and ULINK-ME to both push down a Flash image as well as debug code on the target MCU. But when I try to download the image with Flash Magic, via the LPC-LINK2, I get the error. I believe I have it setup correctly and I have tried various tips to get it working to no avail.

My configuration is Windows 7, FM 10.60, Installed the NXP drivers with FM kit, No jumpers on the LPC-LINK2 (e.g., DFU), 50 mil ribbon from J7 to Adafruit's CORTEX SWD ADAPTER (basically 50 mil 2x5 to 100 mil 2x10), jumper from SWDIO, SWCLK, RESET and GND) to bread-board and then onto PCBA. The jumpers join same BB rows as for ULINK-ME. I have checked and re-checked jumpers and I see nothing wrong with them. I've even run continuity tests from the J7 for the lines I'm interested in to the bread-board to confirm. I am able to select "SWD over Link2" from FM Interface menu. When I conduct my FM tests, the ULINK-ME is not plugged in.

I am at a loss at this point and could use some tips. Any ideas?

Thanks,

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2156
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: SWD over Link2
« Reply #16 on: August 24, 2017, 08:18:11 pm »
As mentioned via email, the SWD communications are not reliable. Sometimes you are getting a parity error, other times a malformed packet. I would suspect an electrical issue between the LPC4300 on the LPC-Link2 and the target part.
Embedded Systems Academy, Inc.
support at esacademy dot com