Flash Magic Forum

In-System Programming Support => P89V51Rx2/P89LV51Rx2 => Topic started by: harnamt on June 06, 2006, 04:08:43 am

Title: Problem with P89V51RD2FA
Post by: harnamt on June 06, 2006, 04:08:43 am
Hello  there !

When I was using this uC
P89V51RD2FA,
CN6014.00
KzNO435 AC
Everything was cool, I could Communicate with hyper terminal and test my programs.



The next assignment I bought from the dealer is with the following
description and now  I can not establish the communication with the
hyper terminal
P89V51RD2FA
CP2821.00
K1G0505AC


What could be the reason ?

Regards

HS THAKUR



Post Edited (06-06-06 04:27)
Title: Re: Problem with P89V51RD2FA
Post by: Jan Waclawek on June 06, 2006, 04:32:07 am
Isn't it stuck in SoftICE mode?
Try this: http://www.esacademy.com/software/flashmagic/forum/read.php?f=1&i=1621&t=1584#reply_1621

Jan Waclawek
Title: Re: Problem with P89V51RD2FA
Post by: harnamt on June 06, 2006, 06:01:41 am
I have tried more than 20 pieces, same problem.
In ISP mode it's Ok, I can download the hex files without any problem.
LCD programs etc are working O.K.

This problem is coming in the the terminal program only. When I insert
the first chip, it.s working

No communication is taking place, the chip does not responds.

Regards



HS THAKUR

Title: Re: Problem with P89V51RD2FA
Post by: Jan Waclawek on June 06, 2006, 06:53:53 am
> This problem is coming in the the terminal program only. When I insert
> the first chip, it.s working
>
> No communication is taking place, the chip does not responds.

I don't understand. Are you trying to get into the bootloader mode using a terminal emulator?

Please elaborate.

Jan Waclawek
Title: Re: Problem with P89V51RD2FA
Post by: harnamt on June 06, 2006, 09:24:42 am
NO, SIR,


I just simply downloaded the hex file for key pad program.
Opened windows hyper terminal and
selected Port,baud rate 9600,data bit 8, Parity None,Stop bit 1,
Hardware None


I am trying to test the matrix key pad program
When any key between S1 to S16 is pressed it displays the corresponding number on the hyper terminal saying
Title: Re: Problem with P89V51RD2FA
Post by: Jan Waclawek on June 06, 2006, 03:09:41 pm
Is there any indication that your "keypad" program is actually running?
E.g. some LEDs flashing etc.

Jan Waclawek
Title: Re: Problem with P89V51RD2FA
Post by: harnamt on June 06, 2006, 06:33:34 pm


The same program when I download on first chip  on the same development board it works OK.
I tried ADC program in hyper terminal where temp reading can be read.

regards

HS THAKUR
Title: Re: Problem with P89V51RD2FA
Post by: Jan Waclawek on June 06, 2006, 11:50:25 pm
Can you try to make a very simple program, such as flashing a LED, to detect if the proper file gets "burned" and is running?


Jan Waclawek
Title: Re: Problem with P89V51RD2FA
Post by: harnamt on June 09, 2006, 09:04:11 pm
Yes, I tried a simple program, blinkyi t's working OK.

The problem coming with this chip is that it does not respond in terminal
program i.e. hyper terminal


Harnam

Title: Re: Problem with P89V51RD2FA
Post by: Jan Waclawek on June 10, 2006, 08:26:05 am
Maybe the problem is in hyperterminal - isn't the HW handshake on?
Hyperterminal has a bad reputation because of the overcomplicated way how to set it up. Try perhaps an alternative terminal program, my favorites are "Tera term" and "terminal by Bray".

Jan Waclawek
Title: Re: Problem with P89V51RD2FA
Post by: erikm on June 12, 2006, 06:29:09 am
here is the real question:

do you believe in the urban legend "you do not need a MAX232(equivalent)?"

Erik