Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - keets

Pages: [1]
1
P89V51Rx2/P89LV51Rx2 / simulator for p89v61rd2
« on: June 18, 2009, 12:45:17 am »
I need a simulator for p89v51rd2.
sience I write code in assembly, the products of keil/frankline are notuseful.
what do I do?

2
I am facing the same problem. I don't know how to solve it. I changed no. of max232 ics. It works only with my older max232 ic.
Either Max 232 ics in the market are faulty or there is some problem with Flash Magic.

3
P89V51Rx2/P89LV51Rx2 / Re: My observations
« on: May 19, 2009, 08:20:44 pm »
1)When I start FM without connecting cable to com port,the usual window of "reset the device"pops up & remain.
But the moment try to connect cable to unpowered 8051 board the unusual message i.e. unable to connect....comes on the screen.
One more thing if I remove MAX232 Chip and start FM it waits for resetting the device.

And more interestingly when I put MAX232 chip from my older tested board everything works fine.
That suggests MAX232 ic is faulty. But I tried out by changing almost dozen Ics. But system works with only with the older Ic.
I am confused... It never happenned.

4
P89V51Rx2/P89LV51Rx2 / Re: 89v51rd2 programming problem
« on: May 19, 2009, 02:07:06 am »
Thanks here is the debugfile.
I started the flash magic. pressed F1. and tried to write hex file into device.
The usual window "reset the device" poped up.
and after few seconds an error window" Failed to read device signature( unable to connect transmit/receive)) ..." was seen on the screen. I pressed F2.

5
P89V51Rx2/P89LV51Rx2 / 89v51rd2 programming problem
« on: May 16, 2009, 06:38:41 am »
I am using flash magic for programming 89v51rd2 devices for past few years.
But recently i have come acroos a problem.
when I start flash magic a window comes up saying "reset the device into ISP mode now" as usual, but before resetting suddenly an error message saying "unable to read signature bytes, please try to connect at lower baud rate" appear on the screen. and then even after resetting it doesnot program the device.
I changed my com port/cable/reinstalled latest flash magic software,tried with no. of devices. But the problem persists.

does anyone came across such a problem anytime? How to overcome it?

Pages: [1]