Author Topic: DTR and RTS waveforms problems  (Read 9030 times)

Haroldo Stark

  • Guest
DTR and RTS waveforms problems
« on: June 16, 2005, 12:09:34 pm »
Hi,

I'm having a problem when I try to program a 89LPC936 with the FlashMagic.
The waveforms on the serial cable DTR and RTS don't have the same forms showed in the "Flash Magic Application Note 1" - figure 12.
With an oscillloscope I see that there is a single pulse of 52ms instead of the 2 narrow pulses.
The cable I made:
pins 1-4-6(DTR) , 7-8(RTS) and 5(GND)

Any suggestion ?
Thanks in advance.

H.Stark


Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2177
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: DTR and RTS waveforms problems
« Reply #1 on: June 16, 2005, 02:52:55 pm »
The three pulses are produced by inverting the transmission of FFH, FFH, FFH, so the pulses should be appearing. Do you have the option to use DTR and RTS turned on in the Advanced Options? Is your scope fast enough? At 20MHz you might struggle to see the pulses.

Embedded Systems Academy, Inc.
support at esacademy dot com

Haroldo Stark

  • Guest
Re: DTR and RTS waveforms problems
« Reply #2 on: June 17, 2005, 04:13:12 am »
Yes the option to use DTR and RTS is turned on.

My scope is 100MHz fast. I'm using the same time-scale from "Flash Magic Application Note 1 - figure 12".

I'm getting the signals(RTS and DTR) on the cable without the circuit connected.

My OS is Windows XP professional.

H.Stark

erikm

  • Guest
Re: DTR and RTS waveforms problems
« Reply #3 on: June 17, 2005, 05:42:35 am »
you do not mention which transciever you use.  There has been problems with some of those.

Erik

Haroldo Stark

  • Guest
Re: DTR and RTS waveforms problems
« Reply #4 on: June 17, 2005, 06:14:48 am »
Hi,

There's no transciever connected.  I'm getting the waveforms on the cable without the circuit with transciever.


The waveforms I got, are similar to the figure 12, but I got a rectangular pulse of 54ms instead of the 2 narrow pulses spaced about 54ms.

H.Stark

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2177
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: DTR and RTS waveforms problems
« Reply #5 on: June 17, 2005, 08:48:53 am »
The relative times between each of the waveforms may not match up with the application note, because since the application note was written we made it possible for T1 and T2 to be configured. The shape of each waveform should be the same however. Could it be that the pulses are occuring later than you expected?

Have you tried hooking DTR and RTS up to the LPC936 to see if it works?

Embedded Systems Academy, Inc.
support at esacademy dot com

erikm

  • Guest
Re: DTR and RTS waveforms problems
« Reply #6 on: June 17, 2005, 02:03:50 pm »
so, if you believe in the urban legend "you do not need a Max232(equivalent)" the reason is obvious.

ERrik

Haroldo Stark

  • Guest
Re: DTR and RTS waveforms problems
« Reply #7 on: June 20, 2005, 10:41:38 am »
Hi,

I don

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2177
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: DTR and RTS waveforms problems
« Reply #8 on: June 20, 2005, 10:46:08 am »
How are you getting the device into ISP mode when using Hyperterminal?

Embedded Systems Academy, Inc.
support at esacademy dot com

Haroldo Stark

  • Guest
Re: DTR and RTS waveforms problems
« Reply #9 on: June 20, 2005, 10:56:21 am »
Before i use the hyper terminal I try send some command with the flash magic. So I suppose that the device is still im isp mode when I send commands by terminal.

H.Stark

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2177
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: DTR and RTS waveforms problems
« Reply #10 on: June 20, 2005, 11:05:02 am »
Try this:

Remove and reapply power to your target
Start the latest version of Flash Magic
Press F1 so [Debug] appears at the top
Choose Read Device Signature... from the ISP menu so it fails.
Press F2 to exit debug mode
Switch to hyperterminal
Send U followed by :00000001FF
Email me the generated debug file C:\flashmagic.fmd
Delete C:\flashmagic.fmd

My email address is at the bottom of this posting.

Embedded Systems Academy, Inc.
support at esacademy dot com

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2177
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: DTR and RTS waveforms problems
« Reply #11 on: June 20, 2005, 11:06:08 am »
I forgot to add, make sure you are using the same baudrate in both FM and Hyperterminal.
Also when you email, include what hyperterminal received back from the device.

Embedded Systems Academy, Inc.
support at esacademy dot com

erikm

  • Guest
Re: DTR and RTS waveforms problems
« Reply #12 on: June 20, 2005, 11:20:06 am »
There's no transciever connected.  ...  and i