XA-G49 erase failure

Started by Simon, September 15, 2003, 02:27:55 PM

Previous topic - Next topic


We have been using Flash Magic for a couple of years now to program XAG49 devices with no problems. However, a new board layout is showing a fault we have not seen before. Flash Magic will connect but will then fail during the 'erase device' stage and will flag up an error that effect.

We have verified the setup with other boards, changed the device, checked the power supply (4.98V) and the reset cct with a scope and all seems fine. However, we cannot get any of these boards to program. The device seems to be communicating with the PC as there is activity on both the Rx and Tx lines of the RS232.

Any suggestions would be gratefully received. We are completely stuck and time is running out.

Many thanks

Andy Ayre

How is the new board different than the old board with respect to the XA-G49 connections? Are you using the same crystal frequency? If you are using a lower crystal frequency then you might need to lower the baud rate as well for reliable communications.

Please go through the steps in the app note "what to do if ISP does not work" (available on the Flash Magic web page) and let me know what you find via Email.

Also if you wish, you can Email me both your schematic diagrams in jpg/etc format and I can take a quick look and see if I can spot anything.


Embedded Systems Academy, Inc.
support at esacademy dot com


Hi Andy, thanks for replying.
I have already worked through that application note and sent the debug file produced by Flash Magic to support@esacademy.com but I hadn't had a reply so I thought I would try this route.

The crystal is 24.576MHz and is the same as we have used on many of our boards. We normally program at 38400 baud but all the tests I have done have been at 9600 baud.

We have verified the PC side of things by programming another board and all seems fine. We have also tried programming one of these suspect boards on another PC but with the same results.

I have also tried the hyperterminal tests. The 'U' is echoed back, but what are the commands for ISP. The XA data sheet only mentions sending a lower case 'f' to establish the baud rate but doesn't mention anymore commands that can be issued via the comm port other than those to load a hex file. I cannot seem to find an erase command.

Sorry to be thick, but what is your email address? Maybe I could forward the debug file directly to you?


erik malund

A totally diffrent situation, but maybe the same problem.

Once when a PCB were laid out (diffrently) again, the watchdog started having problems.  It turned out that the problem was that the trace from the chip to the decoupling capacitor now was abt 1".  Soldering a decoupling cap directly across the supervisor chip took care of the problem.


Andy Ayre

Sorry, there was a hick up with the support email address due to my being ill for a few days. I'll go and retrieve your debug file and take a look.

Embedded Systems Academy, Inc.
support at esacademy dot com


Thanks for the hint Erik,
I have just checked and I have the reset chip directly beneath the socket for the XA, and the decoupling cap is right next to it so hopefully that will be OK. I will try hanging another on the XA just to see what difference it makes.
Certainly worth checking though!


If you need to see what FlashMagic do on our RS232 port,
Use this tool.