Author Topic: LPC922 Virgin chip ISP entry doesnt work.  (Read 3096 times)

Prahlad Purohit

  • Guest
LPC922 Virgin chip ISP entry doesnt work.
« on: October 04, 2005, 06:26:27 am »
 Dear Forum Members,

All factory fresh LPC9xx are meant to enter ISP mode when started for the first time since their status byte is set to 1. Till today I have used Keil MCB 900 type circuit with my LPC922 and it always worked with flashmagic. Today I tried to take the advantage of the factory set + NOTOUCH ISP entry and avoid using Keil MCB 900. The problem I face is when I use a fresh micro keil doesnt detect it. I tried to read status byte security bits etc. In all cases it shows attempting to connect and then says " Unable to conenct at specified baud ....... " I tried all possible bauds 2400, 4800, 7200, 9600, ...... but same response.

What works????

STEP 1. I opened hyperterminal connect to same com port. Baud 2400/4800/7200 8 None 1 No flow cntrl. Type 'u' it echoed some junk typed u again it echoes correctly 'u' then whatever is typed is echoes correctly.

STEP 2. Cloed hyperterminal stareted flashmagic same port same baud and tried reading device signature. It worked. I could do all ISP things including programming.

The above method worked at following baud rates. 2400, 4800 and 7200. If I turn off and then again try with flashmagic it says same cant connect. If I first use hyperterminal send 'u' twice and then open flashmagic it works. Have anybody faced this problem earlier is there something wrong with flashmagic or something else is wrong.

Thanks & Regards,
Prahlad Purohit

Prahlad Purohit

  • Guest
problem solved
« Reply #1 on: October 04, 2005, 11:56:20 pm »
 As I said till now I used Keil MCB900 type method for ISP programming of LPC922. In Advanced Options Use CTS and RTS to Enter ISP mode was set. With only Rx and Tx it should not be set. Removing the tick from this option solves the problem.

Prahlad Purohit