Author Topic: bug in ISP loader P89LV51RC2 version 02 (Block0 not erasing)  (Read 4149 times)

Bonny Gijzen

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
bug in ISP loader P89LV51RC2 version 02 (Block0 not erasing)
« on: January 19, 2007, 02:27:59 am »
Hi,

We recently received a new batch of P89LV51RC2 with ISP loader 02 (whereas we had 01 in the past).
It seems now the Erase Block 0 command isnt working anymore:

:050000040000010000F6 <- Dump content
0000=02041002126400000000003200000000

:020000030100FA.   <- Block 0 erase
:050000040000010000F6 <- Dump content
0000=02041002126400000000003200000000

:03000003080000F2. <- Sector 00-7F erase
:050000040000010000F6 <- Dump content
0000=FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

:020000050002F702. <- Version 02



I tried to contact Philips MCU support but didnt have much result.
(Cant login to nxp forums etc.etc.)

Anyway, hope this helps someone who was similar problem.


Regards
Bonny

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2167
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: bug in ISP loader P89LV51RC2 version 02 (Block0 not erasing)
« Reply #1 on: January 24, 2007, 09:34:49 am »
Have you tried programming the latest bootloader into the device? You can get it from the resources page of this site.
Embedded Systems Academy, Inc.
support at esacademy dot com

Bonny Gijzen

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
Re: bug in ISP loader P89LV51RC2 version 02 (Block0 not erasing)
« Reply #2 on: February 02, 2007, 12:57:51 am »
Thanks.

I will have a look at that resources page.

However, I know there is v05 bootloader for the LV51RD2, but now I am refering to the LV51RC2 device.
The latest bootloader shipped to me was v02 (where v01 I had before was working fine).


Regards
Bonny

Bonny Gijzen

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
Re: bug in ISP loader P89LV51RC2 version 02 (Block0 not erasing)
« Reply #3 on: February 02, 2007, 01:07:58 am »
Ok,


I found an updated bootloader (v03) for the RC2 devices.
It doesnt say anything about the bug being fixed however.
(Anyway, I will update a device with this bootloader and see if it is fixed or not.)


Thank you for pointing this section out,

Bonny