Author Topic: P89V51RD2 Programming Issues (IAP)  (Read 4036 times)

Sunil

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
P89V51RD2 Programming Issues (IAP)
« on: June 20, 2008, 12:17:38 pm »
Hi,
I have worked on 89c51rd2 & migrating to v51rd2.
Though i had gone thru the migration notes & had incorporated all the changes which were required to be done, I am still facing some problems with the Device programming. During the programming (using Programmer:Super Pro Model (XETEK)), it gives a manufacutre or device id error, which I have been ignoring & going ahead with programming.
The device when programmed works fine but when used in the IAP mode there is a problem.It is not able to save the contents which were programmed duing the runtime. I am using IAP function address 0x1fff and clearing the bit BSE and FCE register lower 2 bit before invoking the IAP routine.Kindly help me as to how to go about using IAP, if i am not using it in right way.

Regards,
Sunil.
« Last Edit: June 20, 2008, 12:25:27 pm by Sunil »

Jan Waclawek

  • Full Member
  • ***
  • Posts: 220
    • View Profile
    • EFTON homepage
Re: P89V51RD2 Programming Issues (IAP)
« Reply #1 on: June 24, 2008, 11:59:14 pm »
There are '51RD2-s around with at least two different device id - you should contact the device programmer manufacturer for updated firmware/software to account for this.

As per IAP, this is not really the appropriate forum to deal with this - please come to 8052.com forum with the same question, posting also a short example of your code, stating exactly how does it fail your expectations.

JW