Author Topic: 89v51RD2FN device signature recognition problem  (Read 4894 times)

rajesh K

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
    • Email
89v51RD2FN device signature recognition problem
« on: January 03, 2009, 05:33:12 am »
I used hyperterminal to check... its looping back U's. when i click start in flash magic window, its saying

"device signature can't be read. Proceeding further by inappropriate protocol may make the device unusable. do you want to proceed?"
 
when i answer YES to that, first 2 steps, 1.Connection Settings, 2.Erasing are done by flash magic.
but third step is not done. It says
                "Unable to connect(transmit/receive)"

what could be the problem? somebody help me out.

Jan Waclawek

  • Full Member
  • ***
  • Posts: 220
    • View Profile
    • EFTON homepage
Re: 89v51RD2FN device signature recognition problem
« Reply #1 on: January 05, 2009, 06:23:09 am »
Try to read signature "manually", from hyperterminal. Enter:
:020000050000f9
it should echo the whole line (changing f to F) and append BF. (this is the manufacturer ID).

I'd guess what you see is a local echo or some loopback or the mcu running some application echoing on the UART, and not the bootloader's echo.

JW

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2167
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: 89v51RD2FN device signature recognition problem
« Reply #2 on: January 05, 2009, 08:23:00 am »
Please generate a debug file and send it to us. The instructions are here:

  http://www.flashmagictool.com/debugfile.html

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com