Author Topic: unable to connect at specified baud rate ,try reducing baud rate  (Read 19787 times)

revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
hi,
  I have been using p89v51rd2 from a long time but when it comes to dumping the code using flash magic,i always get some messages.This time i am getting the message unable to communicate,try reducing the baud rate.

i have tried changing each component,i changed the board along with microcontroller,i tried unchecking use dtr and rts option also but none of these are working.

I am struck here from 3 days,help me

revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #1 on: June 15, 2009, 03:56:07 am »
i had selected the wrong device....but after selecting the right device, i am getting error - reset the device into isp mode now

what am i suppose to do

revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #2 on: June 15, 2009, 04:07:39 am »
hi,
  Finally i programmed the device,i have unchecked the use dtr rts option in advanced options and when it displays the warning reset the device into isp mode now,i disconnected power and after a second,i connected the power and it displayed a warning stating that the connected device is wrong and asks yes or no,i clicked on yes and it worked

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2167
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #3 on: June 15, 2009, 08:27:42 am »
If you to go ISP -> Read Device Signature what do you get?

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #4 on: June 17, 2009, 04:53:45 am »
when i try to read device signature, again i get the message reset the hardware into ISP mode now.
once i was successfull. but later when i tried again,i couldn do it.
« Last Edit: June 17, 2009, 05:50:34 am by revamp »

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2167
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #5 on: June 17, 2009, 09:04:20 am »
Flash Magic is struggling to get the device to echo back the autobaud character. The ISP entry on these devices can be tricky and you might want to consider switching to one of the new devices, such as the P89CV51RD2 which uses a pin to enter ISP mode.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #6 on: June 22, 2009, 01:29:38 am »
Dear Andy,
      I thanku very much for answerin my queries, I finally resolved it, now its working fine, all i did was uncheckin the use dtr option in advanced settings and unchecked erase all flash and selected erase flash used by hex. thats all.I hope this might help some one. Once again Thanku Andy.


revamp

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #7 on: June 29, 2009, 01:59:41 am »
Dear Andy,
          I have another problem now. I have flashed a code into 8051 which uses serial communication. but when i want to flash another code, i get the error message as UNABLE TO COMMUNICATE(RECEIVE/TRANSMIT).ENSURE NO OTHER APPLICATIONS ARE USING THE COM PORT.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2167
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: unable to connect at specified baud rate ,try reducing baud rate
« Reply #8 on: June 29, 2009, 07:35:38 am »
Windows thinks another program is using the COM port - perhaps the program you are testing your serial communications with? This happens when Windows rejects Flash Magic's request to open the COM port.

Please start a new topic when posting new questions. Thanks.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com