serial number does not get set in P89V51RD2FBC

Started by dptxp, March 18, 2010, 08:35:26 AM

Previous topic - Next topic


Setting the serial number in this version does not work. The verification can be done ( after power on/off).

Worse, once serial number is set by this version, setting of serial number in older
versions also does not work. You can read signature, security and flash (verify).
No message to use password.

My experiments have cost me the only 5 nos. P89V51RD2 left with me.
Some have boot-loader version 6 and some 7.

It was stupid of me to download this 2 days back and update. Fortunately I had an older version (4.60)
setup file somewhere in one machine.

That works, but not after the serial number set by 5.61.

This is a matter of serious concern.


I have found that some of the P89V51RD2 the serial number does not get set. We can read the code after reset. In some ICs the boot loader also does not get upgraded.

I am having the V7 boot loader and upgrading it for V7 with port pin selection for ISP.

any body has faced this problem? 


Please see the previous post by me.

The problem is with the latest version 5.61.
After that the device can not be locked by serial number by any older version.

I am waiting for a reply.

Andy Ayre

I have tried to reproduce the issues with version 5.61 and it seems to work for me, with bootloader version 4 and 7. Here is my test:

Flash Magic 5.61
P89V51RD2 with no serial number, all flash erased
Bootloader version 4 or 7
Kanda 51Plus Eval Board
Windows XP SP3

Start Flash Magic
ISP -> Read Device Signature
  => works
ISP -> Serial Number, enter "foobar" twice, ASCII input, click on Set Serial Number
Remove power from the device
ISP -> Read Device Signature, wait for prompt to reset device
Apply power to the device
  => Operation failed (please unlock the device by supplying a password)
ISP -> Serial Number, enter "foobar", ASCII input, click on Unlock Device
  => Failed to read the device signature, click on Yes to continue
ISP -> Read Device Signature
  => works

Which older version fails to lock the device after using version 5.61 to lock it? 4.60? If you then go back to 5.61 on the same device can you lock it?

Embedded Systems Academy, Inc.
support at esacademy dot com


Once the serial number is programmed in version 5.61, the device cannot be locked by serial number. Even in version 4.60.
I have tried with 5 ICs. I can not just lock them again by either versions.

I have started using the older 4.60 version which works fine. If serial number is set in 4.60, device cannot be opened,
I have tried to open with 5.61 too.

I have been using RD2 for quite sometime and have posted only after I was sure.


Andy Ayre

I guess I am just not getting it. Here is what I tried.

Locked device using version 5.61
Start Flash Magic 4.60 and attempted to read device signature
  => error that operation is not permitted because device is locked
Unlocked device by entering serial number
Read device signature
  => now works
Reset serial number
Cycled power to device
Read device signature
  => Works
Set serial number to "foobar", ASCII mode
Cycled power to device
Read device signature
  => failed with operation not permitted because the device is locked.

This is a P89V51RD2BA with bootloader version 7 on a Kanda 51Plus board. It is the same device that I tested multiple times yesterday with version 5.61.

So from my tests it appears that both 4.60 and 5.61 are working fine with respect to the locking/unlocking of P89V51RD2 devices.

I think the only option left is for you to send me a debug file so I can compare it with what I get. Instructions are here:

Please do the following:

Start FM 5.61
Lock and unlock the device
Close FM 5.61
Start FM 4.60
Start generating a debug file
Attempt to lock the device
Cycle the power to the device
Attempt to read the signature => this should work for you, doesn't for me
Close FM 4.60

Embedded Systems Academy, Inc.
support at esacademy dot com


Here is the debug file.
I could not see any readable character in notepad.
So it is obviously not text.

I had to power up twice to read device ID.


Andy Ayre

Did you remove and apply power to the device after setting the serial number and before attempting to read the signature? In the debug file it doesn't look like you did but I can't tell for sure. I believe that the serial number only becomes effective after a device reset.

If you did cycle the power then I would suspect a problem with your reset circuit, so check that with a scope.

If you did cycle the power and there is no problem with the reset circuit then I will need to send this to NXP for evaluation as I cannot see why it doesn't work.

Embedded Systems Academy, Inc.
support at esacademy dot com


1) I am aware that the device has to be powered down for the serial number to work. I have been using RD2 for years now.
This is the only way to verify that serial number is set. This is how I found out that it is not working with FM 5.61.

2) Occasionally a device does not go into ISP mode as I just insert the USB power cable to power up after clicking on
'read device signature'. So if I had to do it twice, it was normal. Normally it gets into programming mode in one go.
But not always, even in new device.

3) I checked today again though I am 100% sure of the problem.

4) It was just that I had an older setup file. From where can one download older versions of Flashmagic?

And thanks.

Andy Ayre

As I am unable to reproduce the problem in 5.61 and 4.60 and based on the information I have I can't see why you are running into difficulties, I will pass your debug file to NXP. When I hear back I will post here.

Embedded Systems Academy, Inc.
support at esacademy dot com


Problem vanished in
version 5.75.2177

I lost quite a few in 5.70, was using 4.6, took risk with 1 device
in 5.75.2177. Fortunately all seems OK.