In-System Programming Support > LPC9xx/LPC9xxx

p89lpc931 isp programming issue

(1/4) > >>

See Jay:
I am using p89lpc931 in our board. I have the ISP circuit on our board exactly as it is on keil MCB 900 board. I am using flashmagic tool 6.80 version. I get auto-baud error all the time, and I have tried all sorts of options, and controller refuses to go into programming mode.

Btw, I am using USB-SERIAL convertor for connecting my PC and board. I have also connected and tried on another PC with COM port and I have the same issue. I tried to change the baudrate to lower and higher values. But the nothing seems to work.

I am attaching the image that shows the behavior of RST pin after hitting program button on FM.

I don't see a 3 pulses for some reason on RST pin. After couple of seconds, flashmagic gives the autobaud error and RST pin comes back 'Hi' level, as you can see in the image. Can someone through some light on this.

FYI: I am using the same flashmagic with USB-SERIAL convertor for LPC2362 controller and It works great for ISP programming.

Jay

Andy Ayre:
On my scope the pulses are not visible until I crank up the timebase.

You will need to put your scope on the RS232 transmit line from the PC where it enters the board to check for the three pulses there. If you see them then the logic that connects transmit to RST on your board is wrong.

Andy

See Jay:
Finally we got it to work!
We had a trivial issue in driving LEDs on Rxd/Txd pins. It was overloading those pins.

Thanks for your help!

jay

See Jay:
I have now a reprogramming issue. I have changed following parameters in Flashmagic Device configuration and programmed blinky.hex file.

1. Clock changes: high frequency crystal or resonator (4MHz .. 20MHz) - To enable 12 MHz on board crystal
2. Enabled Reset Pin
3. Enabled Brownout Detection

Erase all flash was selected with Protect ISP Code checked.

We are unable to reprogram the device after this flashing. I am attaching FM debug file with this email for a Read Device Signature option.

Could you help us out on this issue.

Thanks, Jay

Andy Ayre:
Your debug file shows Flash Magic sending the three reset pulses then a 'U'. Nothing is received back. So it seems that the device is not being placed in ISP mode.

I would double-check all the signals again with a scope to make sure nothing has changed there. If it all looks fine then it must be the new configuration somehow that is stopping ISP mode from being entered. Re-reading the user manual/datasheet might yield a clue.

Andy

Navigation

[0] Message Index

[#] Next page

Go to full version