General > General Discussion

Stall + Not authorized

<< < (2/2)

Andy Ayre:
Close FM
Remove jumper JP1 from the LPC-Link2
Connect the LPC-Link2 to your PC - make sure it is recognized by checking in device manager
Start FM

Currently FM only checks for attached debug hardware on startup.

Do you have three different PCs giving the "not authorized" error?

GGD77:
Hi, thanks for prompt reply

yes 3 different PCs give me the "not authorized" error at start-up. One of them (the 1st I tried) also hides the message in the background and I could not see it/read it. It was appearing briefly on the foreground of the opened windows only when I was killing the main FM process from task manager.

Anyway I tried the "roll-back the date trick" does not work.

RE removing JP1
this was the first thing advised in many forums/tutorials for FM including on the NXP documentation I have tried: no joy... and anyway the device was always recognized in device manager at each test.

Last minute update:

Version 10.9 without changing any settings on the LPC-link2 worked... I just did this trial end error uninstalling and re-installing driver+FM for all the versions I could download. the oldest and my last chance just did it... all the others give me the "not authorized" message

Just now I have successfully erased the NHS3152 chip in the evaluation kit I recently purchased. Later will try to flash one of the other example .hex I know can be downloaded from the NXP page.
Regards
GGD

Andy Ayre:
Can you please try this:

Install version 11.00.
Open a command window and go to the FM installation folder
Connect the LPC-Link2 with JP1 removed
Run:

  USBManger --list

What happens? What is output? Do you hear any bings/bongs from Windows? Does the LED on the Link2 start flashing?

Thanks, Andy

GGD77:
Hi, will try doing it from my desktop at work. Currently my laptop with 10.9 programs and works correctly and I do not want to mess it up.
In any case, all 3 computers have always (independently from FM version) done the sound of USB connected device and all of them at 1st connection after installing/re-installing the driver have detected the "new device" and have installed the software. I even tried to connect the device before starting FM and vice-versa few times I also tried to reboot the computer after the first connection... until now... no joy

About the LED blinking on the device, it was always solid until I started the FM10.9 while the software was starting the LED started to blink and I thought it was a good sign. In fact, the elusive option to program the chip over the LPClink2 was there and allowed me to program the chip.

I tested one .hex from NXP works as detailed in the specs.
Regards
GGD

Andy Ayre:
The LED blinking at FM start is a good sign. Did it do that as well as give the "not authorized" error?

Navigation

[0] Message Index

[*] Previous page

Go to full version