General > General Discussion

Slow download which bugs out Chrome

(1/2) > >>

When I attempt to download the latest FlashMagic.exe (version 11), I am barely seeing 30KB/sec download speeds.  I also get network drops which cause Chrome to throw a hissy fit.

If I download the OS X version with Safari, I see a checksum error.

I have also gotten Internal Server Errors.

Is something wrong with the servers or the images on them?  Is there an alternate server from which to download this or a slightly older version?


Andy Ayre:
Hmmm... downloads seem slow for me as well, but using Chrome the downloads are successful. We will keep monitoring it to see if there is a pattern.

Microsoft Edge on Windows 10 requires multiple attempts with "Download interrupted" and restarts and winds up with an incorrect file size.  Chrome on Windows 10 still not downloading.  Comes up with "Failed - No file".  I believe this is a known Chrome bug:!topic/chrome/MA_Kyk8UpEs

Verified on both real LG laptop and virtual machines.

At root, the problem is that I *STILL* cannot get these files downloaded at any useful download rate and then verify the downloaded artifact.

What's my next step to get this resolved?  Do I need to escalate this in a case with NXP?


Andy Ayre:
I just tried Microsoft Edge 41.16299.248.0 on Windows 10 Pro 64-bit version 1709. It downloaded in 10 seconds and opens fine. I then tried it a three more times, clearing the browser cache each time. Always downloaded successfully and takes about 10 seconds.

I then tried Chrome 65.0.3325.181 on the same PC.  Took about 10 seconds, downloaded successfully. I tried it a few more times - always around 10 seconds and always successful.

I then tried Firefox 59.0.2 64-bit on the same PC. Downloads in about 10 seconds, downloads successfully.

We have also tried downloading from UK, USA and Germany - seems to download fine.

I would suspect your internet connection or somewhere between your PC and our server, on the internet perhaps.

Well, today I am seeing speeds of about 100KB/sec so I can actually download it with any browser.  (I note that this is ver 11.01 and not 11.00).

It's certainly possible that there is routing issue, but I'm suspicious.  I tried to access this from behind our corporate ISP (AT&T Business) and my home ISP (Cox Communications).  Both had the same failure.  MY CTO had the same problem from his home ISP.

Interestingly, wget pulls it down smoking fast on Linux (450+ KB/sec).  I'm an idiot for not trying that earlier.  Sorry.

However, that points to something going on at the server (broken browser detection maybe?  IPv6/IPv4 issue? HTTP/2 or SPDY?)

$ shasum -a 256 FlashMagic.exe
8ea579433cbd466e9c4dd1fc92295e25309d4bf3bff041d8068aa9ea530d0664  FlashMagic.exe

In addition, at roughly midnight PST, I got the following when I attempted to download:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Web Server at


[0] Message Index

[#] Next page

Go to full version