Flash Magic Forum

In-System Programming Support => P89V51Rx2/P89LV51Rx2 => Topic started by: harjeet on September 24, 2009, 01:05:23 pm

Title: Unable to connect
Post by: harjeet on September 24, 2009, 01:05:23 pm
I am using FlashMagic on one of my PC and it is working fine, on another one, it gives the following message>>
"Unable to connect at the specified baud rate. Try reducing the baud rate. Reset the hardware into ISP mode again."

On the other PC, even if the serial cable is not attached, it does not show any error message, just it tries to
connect and gives the standard message to "Reset the device in ISP mode."

On this PC, I've tried all from checking the cable, checking the baud rate, checking the port(working fine when checked in Hyperterminal).

Please suggest if any other possibility for such error.
Title: Re: Unable to connect
Post by: Andy Ayre on September 24, 2009, 03:47:30 pm
What is the difference between the setups? One PC has a real COM port and the other uses a USB-RS232 cable? Same serial cable? Same Flash Magic settings (you can save the settings from one and load it into the other)?, same hardware?, same microcontroller?

Title: Re: Unable to connect
Post by: harjeet on September 25, 2009, 01:47:55 am
Thanks for replying Andy.

There is no difference between the two setups, both the PCs have real COM port, however the hardware and the serial cable are different as one of the PC is at my office and one at home.
At office PC, I've installed FlashMagic 6 - 8 months back and since then it is working fine.
Few days back, I've installed the latest version on my home PC and get this error. I've also copied the older version file to my home PC, installed it and tried again with no luck. No extra settings were made in both PCs, just installed Flash Magic, 89V51RD2 IC selected, COM port (COM1 working on both) selected, baud rate set to 9600 and interface to ISP.
As I've mentioned earlier, even if I remove the serial cable from my office PC and then click on start, it shows the message to "Reset the device into ISP mode now", however in home PC, as I click on start, it shows this error message.

Let me know if any other information is required.

Harjeet Singh
Title: Re: Unable to connect
Post by: Andy Ayre on September 25, 2009, 09:21:57 am
What version are you using at work?

So you've tried the exact same version of FM at both home and office and office works and home doesn't? Then I would try taking your hardware and serial cable home and testing that. It could be a bad solder joint or defective power supply for example.

Make sure in Options -> Advanced Options -> Hardware Config you have the DTR option disabled. Also make sure all other settings match between the two PCs.