Recent Posts

Pages: 1 2 [3] 4 5 ... 10
General / Unsupported Operation?
« Last post by JamesM on June 23, 2020, 11:33:11 am »
I am using C++ Builder XE6. I have linked with the Borland C++ 5 DLLs. However, when I run the following code, fm_connect returns "Device does not support operation. Only COM connections supported."

I must be missing something obvious? Thank you in advance for any help - James

Code: [Select]
#include "flashmagicarmcortex.h"

void __fastcall TForm1::Button1Click(TObject *Sender)
  fm_results *presults;
  presults = fm_version();

  fm_connectoptions_com options;


  options.osc               = 12.000;
  sprintf_s(options.comportname, FM_MAXCOMPORTNAMELEN, "COM%d", 5);
  options.baudrate          = 115200;
  options.selecteddevice    = FM_LPC1758;
  options.highspeed         = 0;  //1;
  options.clocks            = 0;
  options.halfduplex        = 0;
  options.hwconfig          = FM_HWBOOTEXEC;
  options.hwt1              = 200;
  options.hwt2              = 200;
  options.i2caddr           = 0;
  options.maxbaudrate       = 115200;
  options.usinginterface    = 0;
  options.interfacetype     = FM_INTERFACETYPE_NONE;
  options.flashbank         = 0;
  options.protocoloptions   = FM_PROTOCOLCOM_AUTOLF;
  options.postopendelay     = 0;
  options.bootloaderpath[0] = NULL;

  presults = fm_connect(&options, sizeof(options));

  if (presults->result != FM_OK)
ARM Cortex / Re: Replacement dongle for FTDI USB-ICP-LPC2K
« Last post by Andy Ayre on May 12, 2020, 12:11:36 pm »
I'm not aware of anything. Have you asked Future Designs? Andy
ARM Cortex / Replacement dongle for FTDI USB-ICP-LPC2K
« Last post by jking on May 12, 2020, 11:26:19 am »

Can anyone recommend a replacement for the obsolete USB-ICP-LPC2K made by FTDI?  We use flash magic with the USB-ICP-LPC2K dongle to erase the read protect bit on an NXP LPC1787.

LPC2xxx / Re: it's about to send program to LPC2148
« Last post by Andy Ayre on April 21, 2020, 09:14:59 am »
Use a USB to RS232 cable, such as one from FTDI. Some of those cables are cheap and don't work properly. Put a MAX232 or similar between the cable and microcontroller. I suggest you look at the schematics of some off-the-shelf LPC2000 eval boards.


LPC2xxx / it's about to send program to LPC2148
« Last post by LPC2148 on April 21, 2020, 05:32:25 am »
Hi all,

I will start to use lpc-h2148 arm board.I have it. I wrote program.
I have a few question which I don't know.
I don't have jtag module
I have paralel and serial port on my pc

question 1) I want to upload program to arm board, Could I upload program via USB port on the arm board? ( I did not try it)

question 2) Could I upload program with USB to TTL  only by using TX,RX,GND?
There are 5 pin on the USB to TTL (+5V,TXD,RXD,GND,+3V)

baund rate 9600
I tried like this flashmagic program, but failed (program gave this error code  operation failed. Failed to autobaund)

USB to TTL >>>> LPC2148
TX         >>>> P0.1 RX
RX         >>>> P0.0 TX
GND        >>>> GND

I need your answer and ideas
with best regards,
LPC2xxx / Re: LPC2148
« Last post by Andy Ayre on March 27, 2020, 08:56:14 am »
The hex file determines where the data goes - it contains the addresses. Andy
ARM Cortex / Re: Program NXP board LPCXpresso54628 using LPC_LINK2
« Last post by Andy Ayre on March 27, 2020, 08:55:03 am »
Is the board still shown in the drop down list in section one?

Did you program it with firmware that disabled SWD? If yes then you won't be able to reprogram it again.

ARM Cortex / Program NXP board LPCXpresso54628 using LPC_LINK2
« Last post by javiergonzalezb on March 27, 2020, 01:06:30 am »
I'm trying to  program the LPCXpresso54628  with Flash Magic Software.
The first Time I could to program the board.
But, the next time when I wanted to program again, Flash Magic show error:

Operation failed. Failed to connect. Try disconnecting and reconnecting the board. Make sure the board appeart in the devices manager.
LPC2xxx / LPC2148
« Last post by mike03590 on March 06, 2020, 02:06:07 pm »
I am a lowly repair tech..(I like my job though) I am loading the frimware and font into an LPC2148 for a small printer...It loads beautifully from Flash Magic. When i try to ,load my file (hex)  called (LOGO) into the LPC 2148 it load, but to the incorrect block...I want block 26 but the logo seems to go to block 25...Can I tell this program where to put the logo file??
LPC2xxx / Re: FlashMagic 12.75 doesn't erase/program LPC2129
« Last post by Andy Ayre on February 03, 2020, 08:32:24 am »
OK, that is something we can address for the next release - thanks for letting us know. Andy
Pages: 1 2 [3] 4 5 ... 10