Author Topic: tried everything for isp-89v51  (Read 5196 times)


  • Guest
tried everything for isp-89v51
« on: January 04, 2005, 01:03:12 pm »

i'm using P89v51rd2.i'm unable to engage the isp mode. i tried repeatedly reseting & also switching on /off the circuit. i had selected the right device. tried changing the baud rates too.nothin seems to work. i'm using a printed kit board which originally supported AT89c51 & have kept p89v51rd2 into it.


  • Guest
Re: tried everything for isp-89v51
« Reply #1 on: January 05, 2005, 04:43:27 am »
My guess is that you have the abnomiable RC reset.  Any circuit without a supervisor is asking for it.


Jan Waclawek

  • Full Member
  • ***
  • Posts: 220
    • View Profile
    • EFTON homepage
Re: tried everything for isp-89v51
« Reply #2 on: January 12, 2005, 11:23:45 pm »
The chip may be in the SoftICE mode. You can check it this way: get a terminal program capable of sending binary/hex characters (e.g. term by bray). Power on your board and send 11h ($11) mulltiple times. If the chip responds alternating $00 and $FF, then it is in SoftICE mode.

Jan Waclawek