89C51RD2BN connectivity problems

Started by Nikolai, January 17, 2007, 06:30:01 AM

Previous topic - Next topic


Im having the same old problem of "Unable to connect at specified baud rate"..

I double checked the connections. I tried communicating through the hyper terminal but "u" is also not being echoed.

any ideas as to wat could be wrong ?

Jan Waclawek

  • micro not working at all

    • no or bad power (check with DMM and/or oscilloscope)
    • no reset (throw away the RC reset if you use it) or "hanging" reset
    • oscillator not working (check with oscilloscope)
  • bad method of entering ISP - check with the appropriate datasheet/appnote
  • faulty RS232 connection - check by pulling the micro from socket (I hope it's socketed) and short Rx and Tx - in terminal you should see echoed characters
  • "bootvector loss" problem - search on this forum

What is the history of this chip? Did you already attempt to program it? Did you run it in a board with inappropriate (=RC) reset?

Jan Waclawek


i checked the power supply...its working fine...
didnt try chucking the reset ckt...
oscillator is working fine

ISP conditions met...(PSEN pulled to GND,Vpp=5V,ALE=NC)

RS232 link is good.. i tried shorting rx n tx, n characters do echo back.

I just got a brand new IC (the second since the first failed for unknown reasons)... so lost boot vector is less probable.




Yes P2.6  n P2.7 is high when the circuit is powered. As a matter of fact PSEN too is high(4.93 volts) when in run mode.

Andy Ayre

A brand new device should power up into ISP mode. Is that the case? If you take a new device and still cannot get the 'U' to echo back then there is something wrong with either the communication path between your PC and the device or an electrical problem.

Have you tried putting a scope on the RxD pin to see if the 'U' is getting there? If it is, put the scope on the TxD pin. Do you see the 'U'?
Embedded Systems Academy, Inc.
support at esacademy dot com