Author Topic: Larger bug when re-programming 89V51RD2  (Read 4110 times)

phonoplug

  • Jr. Member
  • **
  • Posts: 15
    • View Profile
Larger bug when re-programming 89V51RD2
« on: January 24, 2007, 07:52:35 am »
Just upgraded to version 3.42. I use the 'Use DTR to control RST' advanced option, and the target board runs on a 16.384MHz crystal. Before I upgraded I was using 3.20 which worked fine.

I have found in the new version a problem with entering ISP mode - there is a delay between release of the RST line and the 'U' character being sent. I used to have T1=100mS and T2=50mS and this worked fine (and as expected) with version 3.20. The time between release of RST and the begining of 'U' appearing was about 70mS. However, with version 3.42 this time, with the same settings of T1 and T2 is around 375mS, meaning the micro has gone off into normal boot mode by then. Setting T2 even to 0 still gives too longer a delay to catch the micro.

Fortunately I have the installer for version 3.20 still so going back to that works fine, but theres ovbiously something wrong with 3.42!

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2172
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: Larger bug when re-programming 89V51RD2
« Reply #1 on: February 09, 2007, 03:02:33 pm »
This was broken in version 3.39, but is fixed in version 3.46 - just uploaded. Thanks for letting me know!

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com