Author Topic: ISP to ICP and Flash Magic 5.32 1777  (Read 7227 times)

HP-65

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
ISP to ICP and Flash Magic 5.32 1777
« on: August 30, 2009, 06:13:28 pm »
Hi,

I just "upgraded" to the newest version 5.32 1777.

FM complains about an incompatible firmware:
"Operation Failed. (Your ICP interface firmware is not compatible [protocol 255.1]. ..."

Is there anything newer than "ISP to ICP bridge code version 1.7", in "prog90x.zip"?
Bug or feature?


5 minutes ago, everything worked fine...

HP

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2190
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: ISP to ICP and Flash Magic 5.32 1777
« Reply #1 on: September 01, 2009, 09:17:05 am »
Please generate a debug file and send it to me. Instructions are here:

  http://www.flashmagictool.com/debugfile.html

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

setyco93

  • Jr. Member
  • **
  • Posts: 1
    • View Profile
Re: ISP to ICP and Flash Magic 5.32 1777
« Reply #2 on: September 06, 2009, 07:03:28 am »

My ISP to ICP Bridge works normaly with Flash Magic v5.31 but in new version v5.32 all oprations return error

"Operation Failed.(Your ICP interface firmware is not compatible [protocol 255.0]. Please upgrade your copy of Flash Magic)"

Debug file is attached.

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2190
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: ISP to ICP and Flash Magic 5.32 1777
« Reply #3 on: September 08, 2009, 11:21:34 am »
Please try version 5.33 and let us know if you still have a problem.

Andy
Embedded Systems Academy, Inc.
support at esacademy dot com

HP-65

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
Re: ISP to ICP and Flash Magic 5.32 1777
« Reply #4 on: September 08, 2009, 05:00:10 pm »

Seems to work...

thanks
HP