Author Topic: LPC935FDH Can only program first time  (Read 8528 times)


  • Jr. Member
  • **
  • Posts: 1
    • View Profile
LPC935FDH Can only program first time
« on: December 07, 2011, 08:43:22 AM »
 have just made a circuit base on the mcb900 and have tried programming
a LPC935FDH in this circuit. It worked the first time, however when I tried to re-program
it again it would not work and I recieved a unable to communicate message from flashmagic.
Any suggestions on what I am doing wrong

Andy Ayre

  • ESAcademy Staff
  • Sr. Member
  • *****
  • Posts: 2190
    • View Profile
    • Embedded Systems Academy, Inc.
    • Email
Re: LPC935FDH Can only program first time
« Reply #1 on: December 08, 2011, 12:44:01 AM »
Brand new devices reset into the bootloader. Programmed devices do not.

You are probably failing to start the bootloader. Check with a scope that three pulses are being received on the reset pin after power on.

Embedded Systems Academy, Inc.
support at esacademy dot com